CAD – use View > Properties > and set Metric or Inch, this will only apply to the current drawing

The units can be changed within a drawing at any time, all existing unit information will be converted



To set the Default units use View > Defaults this will then apply to all new drawings created.



CAM – the Units information is passed from a drawing when linked from CAD, to change the units use the Setup dialogue that is displayed when you start a new job.



3DCAM

Use Options > View options to set or changes the units.